BH 209 Ignition Failure

BH 209 Ignition Failure

Postby pjajcinovic » January 5th, 2015, 10:14 am

I have had a series of hang fires with BH209 and CCI209M primers in my Long Range Hunter (50Cal). It only seems to happen when it is cold outside. When I work up my loads in September it fires everytime. When it gets below 40 degree outside I get hangfires. I had three in a row this muzzleloader season already. Any suggestions.
pjajcinovic
 
Posts: 4
Joined: January 23rd, 2013, 12:16 pm

Re: BH 209 Ignition Failure

Postby a1smokepole » January 20th, 2015, 8:23 pm

Or you using the plastic jacket ? if so go to the bare primer plug conversion and will fix you up. I us this in my LRH down to -10 and worked fine with CCI 209m primer.
http://www.knightrifles.com/product/bar ... rsion-kit/
a1smokepole
 
Posts: 197
Joined: February 23rd, 2012, 6:29 pm
Location: Mandeville La.

Re: BH 209 Ignition Failure

Postby pjajcinovic » January 22nd, 2015, 9:45 am

Thanks, I have the bare primer breech plug and will try it. I have tried it before but I have to tap on the bolt handle with a leather hammer to dislodge the primer. Do you have a better way to get the primer out?
pjajcinovic
 
Posts: 4
Joined: January 23rd, 2013, 12:16 pm

Re: BH 209 Ignition Failure

Postby GMB54-120 » January 22nd, 2015, 1:14 pm

Try a Win209 instead of the CCIs. They are longer and the anvil wont back out of the cup as easily. They are all i use in my Knights with a Non FPJ plug.
Green Mountain 54-120 Brush Gun
Elite 45 blued
Original DISC 45 SS
LRH 52cal
GMB54-120
 
Posts: 202
Joined: April 19th, 2012, 12:02 pm


Return to Powders & Loads

Who is online

Users browsing this forum: No registered users and 0 guests